Как в 1с сделать расчетный счет основным в 1с

  • Закрыть ... [X]


       Смешной 1С

     

    23.04.10 - 07:23

    Здравствуйте.
    Добавляю новый расчетный счет, который сделать нужно сделать основным. Я ставлю в коде, но он не делается основным. Если потом считывать основной расчетный счет и БИК, то они пустые. Строка = "0"+(Формат(ИмпортБИК, "ЧГ=0")); СпрБРС = СпрБ.СоздатьЭлемент(); СпрБРС.Наименование = "Основной"; СпрБРС.Владелец = Справочники.Контрагенты.НайтиПоНаименованию(Выборка.Наименование).Ссылка; СпрБРС.НомерСчета = ИмпортРС; СпрБРС.Банк = Справочники.Банки.НайтиПоКоду(Строка).Ссылка; СпрБРС. ВалютаДенежныхСредств = Справочники.Валюты.НайтиПоКоду("810"); СпрБРС.ВидСчета = "Расчетный"; СпрБРС.ВидУчета = Перечисления.ВидУчета.БухгалтерскийУчет; СпрН.ОсновнойБанковскийСчет = СпрБРС.Ссылка; // ДЕЛАЮ ОСНОВНЫМ
     
     
       Defender aka LINN

     

    1 - 23.04.10 - 07:26

    СпрБРС.Владелец = Справочники.Контрагенты.НайтиПоНаименованию(Выборка.Наименование).Ссылка; Жесть...
       Смешной 1С

     

    2 - 23.04.10 - 07:30

    Счет основным не ставится, проблема точно не из-за (1)

       Prikum

     

    3 - 23.04.10 - 07:40

    А записать счет, после его создания!? Тебе же это уже говорили?

       Смешной 1С

     

    4 - 23.04.10 - 07:42

    (3) Это само собой, я записываю. Он записывается нормально, разобрался со всеми реквизитами. НО! Не делается основным...

       Prikum

     

    5 - 23.04.10 - 07:44

    (4) Где именно в твоем коде записывается?

       Смешной 1С

     

    6 - 23.04.10 - 07:44

    В самой конфе, при нажатии на кнопку сделать основным, вызывается обработчик с таким кодом, кнопка работает, делает счет основным. Но полезной информации не могу подчерпнуть: Если ЭлементыФормы.БанковскиеСчета.ТекущиеДанные = Неопределено Тогда Возврат; КонецЕсли; Если НЕ ЗначениеЗаполнено(ЭлементыФормы.БанковскиеСчета.ТекущиеДанные.Ссылка) Тогда Возврат; КонецЕсли; Если ОсновнойБанковскийСчет = ЭлементыФормы.БанковскиеСчета.ТекущиеДанные.Ссылка Тогда ОсновнойБанковскийСчет = Справочники.БанковскиеСчета.ПустаяСсылка(); Иначе ОсновнойБанковскийСчет = ЭлементыФормы.БанковскиеСчета.ТекущиеДанные.Ссылка; КонецЕсли; ПроверитьПометкуКнопкиУстановкиОсновногоБанковскогоСчета();
       Смешной 1С

     

    7 - 23.04.10 - 07:47

    (5) Строка = "0"+(Формат(ИмпортБИК, "ЧГ=0")); СпрБРС = СпрБ.СоздатьЭлемент(); СпрБРС.Наименование = "Основной"; СпрБРС.Владелец = Справочники.Контрагенты.НайтиПоНаименованию(Выборка.Наименование).Ссылка; Сообщить ("Владелец - " + Выборка.Ссылка.ПолучитьОбъект()); СпрБРС.НомерСчета = ИмпортРС; Сообщить("Банк - " + Справочники.Банки.НайтиПоКоду(Строка).Ссылка); СпрБРС.Банк = Справочники.Банки.НайтиПоКоду(Строка).Ссылка; СпрБРС. ВалютаДенежныхСредств = Справочники.Валюты.НайтиПоКоду("810"); СпрБРС.ВидСчета = "Расчетный"; СпрБРС.ВидУчета = Перечисления.ВидУчета.БухгалтерскийУчет; СпрН.ОсновнойБанковскийСчет = СпрБРС.Ссылка; ЗаписьФАдрес = РегистрыСведений.КонтактнаяИнформация.СоздатьМенеджерЗаписи(); ЗаписьФАдрес.Объект = Справочники.Контрагенты.НайтиПоКоду(СпрН.Код); ЗаписьФАдрес.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес; ЗаписьФАдрес.Вид = Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000008"); ЗаписьФАдрес.Представление = ИмпортАдрес; ЗаписьФАдрес.ЗначениеПоУмолчанию = 1; Попытка СпрБРС.Записать(); СпрН.Записать(); ЗаписьФАдрес.Записать(); Исключение Предупреждение("Не удалось записать объект """ + СпрН + """ |" + ОписаниеОшибки(),60); КонецПопытки;
       Prikum

     

    8 - 23.04.10 - 07:47

    (6) Ты не внимательно прочитал мой вопрос, еще раз, где именно в твоем коде записывается созданный ТОБОЙ элемент справочника?

       Prikum

     

    9 - 23.04.10 - 07:49

    (7) У тебя идет присвоение реквизита перед записью того, что присваиваем!

       Смешной 1С

     

    10 - 23.04.10 - 07:52

    (9) Точно. Спасибо ОГРОМНОЕ Вам!

     
      Рекламное как в 1с сделать расчетный счет основным в 1с место пустует

      Рекламное место пустует

    Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.

    ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

    Ветка сдана в архив. Добавление сообщений невозможно.
    Но вы можете создать новую ветку и вам обязательно ответят!
    Каждый час на Волшебном форуме бывает более 2000 человек.

    Рекламное место пустует


    Поделись с друзьями



    Рекомендуем посмотреть ещё:



    Как изменить банковский счет по умолчанию? - 1С Бухгалтерия Как сделать коробку для модели

    Как в 1с сделать расчетный счет основным в 1с Как в 1с сделать расчетный счет основным в 1с Как в 1с сделать расчетный счет основным в 1с Как в 1с сделать расчетный счет основным в 1с Как в 1с сделать расчетный счет основным в 1с Как в 1с сделать расчетный счет основным в 1с Как в 1с сделать расчетный счет основным в 1с Как в 1с сделать расчетный счет основным в 1с

    ШОКИРУЮЩИЕ НОВОСТИ